Results 1 to 4 of 4

Thread: Plugin PHP help

  1. #1
    New to vBFAQ Redline's Avatar
    Join Date
    Apr 2007
    Location
    Camp Lejeune, NC
    Posts
    8

    Plugin PHP help

    Ok, since there's no vB 4 section for this, I guess I can post this here lol. If not, please move it.

    Anyway, I've been playing around with tearing a few modifications apart and trying to make it to where you have to have a minimum number of posts to post links in signatures. But, I'm a little stuck lol. This is what I have in my plugin so far. Hook location: profile_updatesignature_start
    PHP Code:
    global $vbulletin$foruminfo;
    $pagetext =& $this->fetch_field('pagetext''post');
    $excludedugs explode(","$vbulletin->options['usml_siglink_exug']);
            if (!
    is_member_of($vbulletin->userinfo$excludedugs))
            {
            if (
    $vbulletin->options['usml_siglink_enable'] && $vbulletin->userinfo['posts'] < $vbulletin->options['usml_siglink_minposts'])
            {
            if (
    stristr($pagetext,'http://') || stristr($pagetext,'www.') || stristr($pagetext,'@') || stristr($pagetext,'[URL') || stristr($pagetext,'[url') || stristr($pagetext,'.com') || stristr($pagetext,'.org') || stristr($pagetext,'.net') || stristr($pagetext,'.gov') || stristr($pagetext,'.biz') || stristr($pagetext,'.info') || stristr($pagetext,'.tv'))
            {
            
    standard_error(fetch_error('usml_siglink_msg'$vbulletin->userinfo['username'], vbulletin->options['usml_siglink_minposts'], $vbulletin->userinfo['posts']));
            }
            }
            } 
    Apparently what I have doesn't work as I can still post links in my signature. So a variable must be wrong and/or some additional code is needed, which I'm not sure what it is, or if the above is even correct to start with. So any guidance you can give me will be greatly appreciated

    Thank you

    (Running vB 4.1.3)

  2. #2
    New to vBFAQ Redline's Avatar
    Join Date
    Apr 2007
    Location
    Camp Lejeune, NC
    Posts
    8
    This has been solved. Thanks everyone!

  3. #3
    New to vBFAQ
    Join Date
    Jan 2012
    Posts
    20
    Redline, there is nothing so annoying as Googling an issue and finding someone with the same problem who posts back "This has been solved". Please be kind and post the solution. Thanks!

  4. #4
    New to vBFAQ Redline's Avatar
    Join Date
    Apr 2007
    Location
    Camp Lejeune, NC
    Posts
    8
    I've released this as a modification on vBulletin.org. You may check it out there if you like

Similar Threads

  1. Plugin manager
    By BlueHalo in forum vBulletin Discussion and Questions
    Replies: 0
    Last Post: 08-17-2009, 12:41 AM
  2. Need help del vbseo plugin
    By Scott X in forum vBulletin Discussion and Questions
    Replies: 1
    Last Post: 05-06-2008, 02:31 AM
  3. Plugin Support....
    By Half Pint in forum Setting up and Customizing your Forum
    Replies: 0
    Last Post: 09-21-2007, 03:46 PM
  4. Requesting Help With a plugin -
    By Peggy in forum Hack Discussion and Requests
    Replies: 5
    Last Post: 07-09-2007, 07:17 AM
  5. HELP: plugin using curl
    By manish in forum Hack Discussion and Requests
    Replies: 3
    Last Post: 06-15-2006, 10:05 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •